Failed to start bean 'documentationPluginsBootstrapper’
Failed to start bean 'documentationPluginsBootstrapper’
Last edited 2023-6-10
type
Post
status
Published
date
Jun 10, 2023
slug
documentationPluginsBootstrapper
summary
Failed to start bean 'documentationPluginsBootstrapper’
tags
springboot
swagger
category
技术分享
icon
password
springboot 集成swagger报这个
Failed to start bean 'documentationPluginsBootstrapper'; nested exception is java.lang.NullPointerException
notion image
springboot的版本是:2.7.12
swagger的版本是:2.9.2
查了一下网上的,发现是由于两个版本不兼容导致的,最简单的办法是直接修改一下配置,在application.yml中添加这个:
mvc: pathmatch: matching-strategy: ANT_PATH_MATCHER
还可以修改版本,详情见参考文档:
  • springboot
  • swagger
  • mybatis plus整合flowable jar包冲突IDEA git is not installed
    Catalog